Some customers are unable to login to Sage Intacct. They receive 503 or 522 errors.
Incident Report for Sage Intacct
Resolved
This incident has been resolved.
Posted Dec 14, 2020 - 15:11 PST
Investigating
We are currently investigating this issue.
Posted Dec 14, 2020 - 13:30 PST
This incident affected: Sage Intacct - North America (US) (Sage Intacct - North America (US)).